حفره‌ی امنیتی Bash موجب بحران اینترنتی می‌شود؟ هشدار متخصصان در م

حفره‌ی امنیتی Bash موجب بحران اینترنتی می‌شود؟ هشدار متخصصان در م


گزارش‌های جدید در خصوص باگ Bash موسوم به Shellshock وضعیت بدتری پیدا کرده‌اند. آسیب‌های احتمالی ناشی از این باگ رو به گسترش بوده و بسیاری از وصله‌های امنیتی اولیه ناکارآمد به نظر می‌رسند. بر خلاف باگ خونریزی قلبی، حملات اجرا شده با استفاده از باگ Shellshock امکان اجرای از راه دور کدهای مخرب را فراهم ...بیا تو تفریححفره‌ی امنیتی Bash موجب بحران اینترنتی می‌شود؟ هشدار متخصصان در مورد حملات گسترده]]>

گزارش‌های جدید در خصوص باگ Bash موسوم به Shellshock وضعیت بدتری پیدا کرده‌اند. آسیب‌های احتمالی ناشی از این باگ رو به گسترش بوده و بسیاری از وصله‌های امنیتی اولیه ناکارآمد به نظر می‌رسند. بر خلاف باگ خونریزی قلبی، حملات اجرا شده با استفاده از باگ Shellshock امکان اجرای از راه دور کدهای مخرب را فراهم می‌کند که به واسطه‌ی آن شخص خرابکار می‌تواند به گسترش بدافزار بپردازد.

 اغلب حملات احتمالی با استفاده از این باگ در حقیقت وب‌سرورها و دستگاه‌های شبکه را هدف قرار می‌دهد که البته متخصصان امنیتی مدعی هستند که اپلیکیشن‌های PHP مبتنی بر وب بیشترین احتمال آسیب‌پذیری را در خود دارند. همچنین این احتمال وجود دارد که لوازم خانگی هوشمند و دستگاه‌های مجهز به سیستم‌عامل توکار (embeded) نیز در دراز مدت در مقابل این باگ آسیب‌پذیر باشند چرا که اینگونه دستگاه‌ها معمولا برای دریافت بروزرسانی و وصله‌ی امنیتی سرعت عمل خوش‌نامی ندارند. گزارش‌های اولیه هشدار می‌دهند که ممکن است تعداد بسیار زیادی از دستگاه‌ها در معرض خطر قرار داشته باشند. دیوید جیکوبی از آزمایشگاه امنیتی Kaspersky می‌گوید که “مقیاس واقعی و دقیق مشکل هنوز مشخص و روشن نیست”.

در یک سرشماری اولیه، رابرت دیوید گراهام از Errata Security با اجرای یک اسکن آی‌پی محدود، پیش از کرش کردن عملیات اسکن موفق به یافتن ۳,۰۰۰ سامانه سیستم آسیب‌پذیر در مقابل این حفره‌ی امنیتی شد. این آزمایش مشخص کرد که وب‌سرورهای توکار فعال بر روی پورت‌های غیرعمومی نیز بطور خاص و مخصوص در ریسک قرار داشته‌اند. چند ساعت پس از آن، گراهام کشف کرد که شخص دیگری نیز در حال استفاده از همین تاکتیک اما با نیت نه چندان خیر بوده است “به نظر می‌رسد شخصی در حال اجرای اسکن گسترده برای پخش کردن بدافزار است، احتمالا آن‌ها پیش از صبح فردا بسیاری از این سیستم‌ها را مورد نفوذ قرار خواهند داد”.

نتیجه‌ی این اطلاع رسانی اکنون با عنوان کرم “تشکر، راب!” شناخته می‌شود و متخصصان امنیتی نگران هستند که بسیاری از حملات پیش از نصب وصله‌ی امنیتی توسط مدیران سیستم‌ها صورت گیرند. به دلیل آنکه بسیاری از سخت‌افزارهای شبکه بر مبنای سیستم‌عامل‌های شبه یونیکس فعالیت می‌کنند، بسیاری از روترها و سوئیچ‌هایی که زیربنای اینترنت را شکل داده‌اند در مقابل این حمله آسیب‌پذیر خواهند بود که امکان از کنترل خارج شدن اوضاع را محتمل خواهد کرد. ریچارد استینن می‌گوید “این کدهای مخرب قادر هستند با سرعت بالایی یک بحران اینترنتی از نوع SQL Slammer را ایجاد کنند.” و در ادامه به حمله‌ای که در سال ۲۰۰۳ صورت گرفت اشاره می‌کند که به شکل شدیدی موجب کاهش سرعت ترافیک اینترنت شد.

خدای من. این مساله می‌تواند کل اینترنت را برای ساعت‌ها فلج کند. من می‌روم چند دقیقه گوشه‌ی اتاق گریه کنم!

اپراتورهای شبکه تایید کرده‌اند که این باگ هم‌اکنون تحت سواستفاده‌ی هکرها قرار دارد. شبکه‌ی ارائه‌ی محتوای اینترنتی CloudFlare که بخاطر کنترل بخش عظیمی از ترافیک اینترنت شناخته شده است، مجموعه‌ای از اصول دیواره‌ی آتش اپلیکیشن‌های وب را ارائه کرد تا بتواند از وب‌سایت‌های تحت خدمات خود حفاظت کند اما از آن زمان تا کنون، هکرها با استفاده از این ابزار خطرناک مرگ آفرین جدید مجموعه‌ای گسترده و متنوع از حملات اینترنتی را ترتیب دیده‌اند. جان گراهام از CloudFlare می‌گوید:

ما تا کنون شاهد تلاش هکرها برای دریافت فایل‌های پسورد، دانلود بدافزار به داخل دستگاه‌ها، دریافت دسترسی از راه دور، و… بوده‌ایم. حتی حمله‌ای در جریان بوده که باز و بسته شدن در دیسک CD/DVD سرور را نیز درگیر کرده است!

سخت‌افزارهای شبکه در سطوح بالاتر نیز ممکن است تحت تاثیر آسیب‌پذیری باشند. اشکان سلطانی، محقق و ژورنالیست می‌گوید که هشدار دهنده‌ترین حمله‌ای که تا کنون دیده مربوط به آسیب‌پذیری Bash بوده که در سرویس BIG IP متعلق به F5 رخ داده است که بعنوان یک دروازه‌ی هوشمند میان وب‌اپلیکیشن‌ها و کاربر قرار می‌گیرد. آسیب‌پذیری این سرویس در خارج از محدوده‌ی دسترسی عمومی قرار دارد و برای اجرای حمله‌ی موفق لازم است یک کاربر تایید شده‌ی F5 با سطح دسترسی مشخص باشید؛ اما این مساله نمایانگر سطح بسیار بزرگ و عظیم‌تر و خطرناک‌تر حملات ناشی از آسیب‌پذیری Bash است. سلطانی‌ می‌گوید:

بسیاری از سیستم‌های شبکه‌ی سطح بالا بر پایه‌ی پلتفرم لینوکس/یونیکس فعالیت می‌کنند که می‌تواند بارها آسیب‌پذیرتر باشد. یک آسیب‌پذیری در تجهیزات هسته‌ای و اصلی شبکه، بسیار مشکل‌زا تر از سامانه سیستم تکی یک کاربر است چرا که امکان اجرای حملات ریدایرکت و Man-in-the-middle را فراهم می‌کند.

به عبارتی کوتاه و ساده، ما اکنون شاهد مسابقه‌ای میان جمعیت فعال در حوزه‌ی IT و امنیت و نیز انتشار دهندگان بدافزار هستیم. وصله‌های امنیتی به سرعت برای بسیاری از توزیع‌های لینوکس در دسترس قرار گرفته‌اند اما بسیاری از افراد نیز بر این باور هستند که این وصله‌ها تنها می‌تواند راه‌حلی موقتی برای خریدن زمان به منظور مقابله‌ی جدی‌تر با این مساله باشد. Secunia Security به ارائه‌ی مطلبی پرداخته که مدعی است وصله‌ی ارائه شده توسط گنو (GNU) در حل این مساله ناتوان است. همینطور یکی دیگر از محققان می‌گوید “اگر قرار بود شرط‌بندی کنم، شرط خود را بر روی دوام آوردن بلند مدت این وصله‌ی امنیتی قرار نمی‌دادم.”

سیستم‌عامل‌ها و نرم‌افزارهای انحصاری معمولا در مواجهه با اینگونه باگ‌های خطرناک مرگ آفرین تلاش می‌کنند موضوع را سربسته نگاه داشته و بدون اطلاع‌رسانی و از طریق ارائه‌ی بروزرسانی مربوطه مشکل را به کوچک‌ترین وضعیت عمومی تقلیل دهند. اما به نظر می‌رسد اطلاع‌رسانی سریع متخصصین ردهت در مواجهه با این حفره‌ی امنیتی، در نقطه‌ی تصاویر و عکس موجب اطلاع سریع‌تر هکرها و بحرانی شدن وضعیت شده است.

این که وضعیت موجود در واقع تا این حد خطرناک مرگ آفرین است یا تنها با جوسازی رسانه‌ای روبرو هستیم بزودی مشخص خواهد شد. هرگونه اطلاعات تکمیلی در خصوص مسائل مربوط به حفره‌ی امنیتی Shellshock را به اطلاع شما خواهیم رساند.

برای بررسی آسیب‌پذیر بودن سامانه سیستم در مقابل این باگ، دستور زیر را در خط فرمان (بش) سامانه سیستم اجرا کنید:

env X=”() { :;} ; echo shellshock” /bin/sh -c “echo completed”

env X=”() { :;} ; echo shellshock” `which bash` -c “echo completed”

در صورتی که در خروجی، عبارت Shellshock را مشاهده کردید شما نیز در معرض آسیب قرار دارید. بنابراین اطمینان حاصل کنید که سریعا سامانه سیستم خود را بروزرسانی نمایید. اغلب توزیع‌های مطرح لینوکس نظیر اوبونتو، دبیان و سیستم‌های بر پایه‌ی آن‌ها، و سیستم‌های بر پایه‌ی ردهت و فدورا نظیر CentOS و نیز آرچ و اوپن سوزه و… هم‌اکنون وصله‌ی امنیتی مربوطه را از طریق بروزرسانی در دسترس قرار داده‌اند.


جهت اطلاع از آخرین تغییرات وب سایت نازترین در خبرنامه وبلاگ ثبت نام کنید:




نظرات شما عزیزان:

نام :
آدرس ایمیل:
وب سایت/بلاگ :
متن پیام:
:) :( ;) :D
;)) :X :? :P
:* =(( :O };-
:B /:) =DD :S
-) :-(( :-| :-))
نظر خصوصی

 کد را وارد نمایید:

 

 

 

عکس شما

آپلود عکس دلخواه:



جمعه 4 مهر 1393